Table of Contents

Visual3D Menus

EDIT IN PROGRESS

Most features in Visual3D can be accessed in multiple ways. The drop-down menus across the top of the Visual3D application window offer a familiar method of program interaction that is common to Windows-based software.

menus1_arrow.jpg

This page provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here.

File Menu

The File menu item is used to manage files opened or saved by Visual 3D.

filemenu.jpg

Menu Item Description
New Closes all open files, leaving a new, i.e., empty, workspace.
Open/Add Opens a new motion document (C3D, CMZ, H5, etc.)
Close Closes the currently active motion file(s) as indicated by the active file selection box.
Save Workspace Saves all open files to the current workspace document (CMZ or H5).
Save Workspace As Prompts the user with the file save dialog in order to save all open files to a new or existing workspace document (CMZ or H5).
Save Workspace With Embedded Segment Graphics As Workspace files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). This option allows the user to include the wire mesh frames within the workspace file.
Export
> Export C3D File Exports an opened file to a C3D File (.c3d).
> Export C3DFile for Vicon Polygon Runs the pipeline command Export_Polygon_C3DFile.
> Export Animation to AVI Exports the 3D animation to an AVI (.avi) file.
> Export Animation Frame to Image Exports the current animation viewer frame to a supported image file format (.jpg, .png, .gif, .bmp).
> Export OpenSim Motion File
> Export OpenSim Motion File without CleanUp
> Export OpenSim Motion File from Data Tree
View Workspace History
Open Report Template
Append Report Template
Save Report Template
Add/Modify File Tags Brings up a window to add/modify file tags for currently open motion files in the workspace.
Add/Modify Synchronized Video Files Add_Modify_Synchronized_Video_Files Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback.
Add/Modify Synchronized Motion Files Add_Modify_Synchronized_Motion_Files Allows multiselection of C3D motion files and frame offsets for synchronized playback.
Print Prints the current report.
Print Preview Previews the current report before printing.
Print Setup Change the printer and printer options used by Visual3D.
< Recently Opened Motion Files > Displays the last four opened motion files for easy re-opening.
Exit Exits the Visual 3D application.

Edit Menu

Most of the items in the Edit menu, such as Copy, Paste, and Cut, provide behaviour that is consistent with these commands across the operating system.

Menu Item Description
Program Options Opens the Program Options dialog, which allows the user to modify Visual3D's default folders and default viewing options.

View Menu

The view menu contains commands related to Visual3D's graphical interface.

viewmenu.jpg

Menu Item Description
Toolbar Toggles the toolbar on/off. toolbar.jpg
Status Bar Toggles whether status updates appear in the application's bottom bar. statusbar.jpg
Program Options Opens the Program Options dialog with the 3D Animation View tab active.
Large Toolbar Toggles between large and small toolbar icons. smalltoolbar.jpg
Long Filenames Toggles between displaying files as the filename or the complete path on disk. smallfilename.jpg longfilename.jpg
View HAS-Motion Visual3D Banner
View Color Mapped Lines on Signal and Event Processing Graphs Toggles whether lines on the interactive graphs are black or coloured according to file.
View Graph Animation Frame Line Add a vertical line indicating the current frame in the animation window.
View Synchronized Video View Synchronized Video
Set Camera Perspective Set the camera view in the 3D Viewer.

Processing Results

Displays the last set of Pipeline Processing Results

processingresults.jpg

Model Menu

The model menu is dedicated to features related predominantly to a Link Model.

modelmenu1.jpg

When no model is loaded in Visual3D only the option to create a model is available.

Create (Add Static Calibration File)

Creates a new model (Hybrid, 6DOF, Helen Hayes & Derived...) A static calibration file must be opened with the new model because there is a direct one-to-one link between the standing trial and the model.

See this tutorial.

When a model is loaded the following features are available

modelmenu2.jpg

Compute Model Based Data

Brings up a window to create or modify model based calculations (such as joint angles, joint powers, etc.) The resulting data is created on the files specified in the file selection combo.

Assign Model to Motion File

Allows the user to specify which model is to be applied to each movement trial.

Close Model

Closes the current model

Convert Model To Hybrid

Convert a Visual3D Legacy model to a Hybrid Model

Apply Model Template

Opens a model template file (.mdh, .mod, .bsp) to be applied to the currently active model. All existing segments, landmarks, etc. are deleted prior to applying the new template

Save Model Template

Saves the currently active model to a file (.mdh, .mod).

Append Model Template

to current model Adds the segment, landmarks, etc in the template to the current model without deleting the current attributes

Modify Subject Mass and Height

Modify the model properties. Note that these values are also subject metrics that can be edited in the Subject Data/Metrics property page

Modify Frame Range for Subject Cal

Modifies the frame range to use for the subject calibration file.

View/Edit Segment to Force assignments

Modify the segment assignments

Color Item with Signal Value

Allows the user to map signals to segments, and select color values to color a segment based upon the signal values.

Force

Minimum Force

Visual3D's Force menu contains an option to set a threshold for force platform/structure data.

minimumforcemenu.jpg

Applying a threshold value to the force signals ensures that If the computed force is less than the minimum force, then the FORCE and FREEMOMENT are set to zero, the COFP is set to DATA_NOT_FOUND. This value can also be set using the pipeline command Set_Force_Platform_Threshold. This command is listed under the Force category of the pipeline commands. This threshold value is used to remove noise from the force signals. Often for instrumented treadmills this value must be set higher than for overground gait trials.

minimumforcedlg.jpg

Settings

The Program Settings menu item is used to manage various properties of motion files and the Visual 3D environment.

modifytargetsize1.jpg

Modify Lab Coordinate System

Changes the X, Y and Z directions for the lab.

Modify Scale of the 3D Graphics Objects

Allows the user to change the size of the displayed targets.

modifytargetsize2.jpg

Use Processed Analogs for Ground Reaction Force Calculations

Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force

amti_tutorial5.jpg

Use Processed Forces for Segment to Force Assignment

Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the Force Assignments.

Use Processed Targets for Model/Segment/LinkModelBased Items

Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, etc.

An explanation for Using Processed Signals is here

Use Biomechanics Conventions

Biomechanics conventions refer to the meaning for medial/lateral, anterior/posterior, and axial for the left and right side segments.

Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments.

If the name of a segment begins with the letter L, and Biomechanics Conventions are selected, the segment is treated as a left side segment, otherwise the segment is treated as a right side segment.

If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards.

Use Compatible 1 Byte Characters

There are some unicode characters that Visual3D cannot recognize.

Use dd/mm/yyyy (European/Canadian format) Dates

Pipeline Menu

pipelinemenu.jpg

The pipeline menu contains the recent pipelines that were executed. Selecting a pipeline will cause it to be loaded and executed automatically.

Select View Pipeline is equivalent to selecting the View Pipeline icon on the Toolbar.