visual3d:getting_started:menus
Differences
This shows you the differences between two versions of the page.
| Both sides previous revisionPrevious revisionNext revision | Previous revision | ||
| visual3d:getting_started:menus [2024/12/12 11:30] – wikisysop | visual3d:getting_started:menus [2026/08/27 19:34] (current) – Reformatting sections into tables and updating to current UI. richard | ||
|---|---|---|---|
| Line 1: | Line 1: | ||
| - | ====== Menus ====== | + | ====== |
| - | Although many of the features in Visual3D can be accessed in multiple ways, the drop-down menus across the top of the Visual3D | + | EDIT IN PROGRESS |
| + | |||
| + | Most features in Visual3D can be accessed in multiple ways. The drop-down menus across the top of the Visual3D | ||
| {{: | {{: | ||
| - | This Visual3D Menus link provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here. | + | This page provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here. |
| ===== File Menu ===== | ===== File Menu ===== | ||
| Line 11: | Line 13: | ||
| The File menu item is used to manage files opened or saved by Visual 3D. | The File menu item is used to manage files opened or saved by Visual 3D. | ||
| - | {{ : | + | {{: |
| - | The menu subitems are: | + | ^ Menu Item ^ Description ^ |
| - | + | | New | Closes all open files, leaving | |
| - | === New === | + | | Open/Add | Opens a new motion document (C3D, CMZ, H5, etc.) | |
| - | + | | Close | Closes the currently active motion file(s) as indicated by the active file selection box. | | |
| - | Closes all open files, leaving | + | | Save Workspace |
| - | + | | Save Workspace As | Prompts the user with the file save dialog in order to save all open files to a new or existing | |
| - | === Open === | + | | Save Workspace With Embedded Segment Graphics As | Workspace files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). This option allows the user to include the wire mesh frames within the workspace file. | |
| - | + | | Export | |
| - | Opens a new motion document (C3D, CMZ, etc.) | + | | > Export C3D File | Exports an opened file to a C3D File (.c3d). |
| - | + | | > Export C3DFile for Vicon Polygon | |
| - | === Close === | + | | > Export Animation to AVI | Exports the 3D animation to an AVI (.avi) file. | |
| - | + | | > Export Animation Frame to Image | Exports the current animation viewer frame to a supported image file format | |
| - | Closes the currently active motion file(s) as indicated by the active file selection box. | + | | > Export OpenSim Motion File | | |
| - | + | | > Export | |
| - | === Save Workspace | + | | > Export OpenSim Motion File from Data Tree | | |
| - | + | | View Workspace History | | | |
| - | Saves all open files to the current | + | | Open Report Template | | |
| - | + | | Append Report Template | | | |
| - | === Save Workspace As === | + | | Save Report Template | | |
| - | + | | Add/Modify File Tags | Brings up a window to add/modify file tags for currently open motion files in the workspace. | | |
| - | Prompts the user with the file save dialog in order to save all open files to a new or existing | + | | Add/Modify Synchronized Video Files | [[Add_Modify_Synchronized_Video_Files]] Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. |
| - | + | | Add/Modify Synchronized Motion Files | [[Add_Modify_Synchronized_Motion_Files]] | |
| - | ---- | + | | Print | Prints the current report. | |
| - | + | | Print Preview | |
| - | === Export | + | | Print Setup | Change the printer and printer options |
| - | + | | < Recently Opened Motion Files > | Displays the last four opened motion files for easy re-opening. | | |
| - | {{ : | + | | Exit | Exits the Visual 3D application. |
| - | + | ||
| - | == Export C3D File == | + | |
| - | + | ||
| - | Exports an opened file to a C3D File (.c3d). | + | |
| - | + | ||
| - | == Export C3DFile for Vicon Polygon | + | |
| - | + | ||
| - | Pipeline Command | + | |
| - | + | ||
| - | [[Visual3D: | + | |
| - | + | ||
| - | == Export Animation to AVI == | + | |
| - | + | ||
| - | Exports the 3D animation to an AVI (.avi) file. | + | |
| - | + | ||
| - | == Export Animation Frame to Image == | + | |
| - | + | ||
| - | Exports the current animation viewer frame to an Image (.jpg, .png, .gif, .bmp). | + | |
| - | + | ||
| - | == Export | + | |
| - | + | ||
| - | CMO files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). | + | |
| - | + | ||
| - | CMO files intended for the Free CMO viewer, however, must explicitly embed the graphics by selecting the export option to include the graphics. | + | |
| - | + | ||
| - | ---- | + | |
| - | + | ||
| - | === Add Modify File Tags === | + | |
| - | + | ||
| - | Brings up a window to add/modify file tags | + | |
| - | + | ||
| - | === Add_Modify_Synchronized_Video_Files === | + | |
| - | + | ||
| - | [[Add Modify Synchronized Video Files]] | + | |
| - | + | ||
| - | Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. | + | |
| - | + | ||
| - | === Add Modify Synchronized Motion Files === | + | |
| - | + | ||
| - | Allows multiselection of C3D motion files and frame offsets for synchronized playback. | + | |
| - | + | ||
| - | === Modify Force Platform Parameters === | + | |
| - | + | ||
| - | Allows modification of the active file(s) force platform C3D file parameters | + | |
| - | + | ||
| - | === Print === | + | |
| - | + | ||
| - | Prints the current report | + | |
| - | + | ||
| - | === Print Preview | + | |
| - | + | ||
| - | Previews the current report. | + | |
| - | + | ||
| - | === Print Setup === | + | |
| - | + | ||
| - | Change the printer and printer options. | + | |
| - | + | ||
| - | === Exit === | + | |
| - | + | ||
| - | Exits the Visual 3D application. | + | |
| ===== Edit Menu ===== | ===== Edit Menu ===== | ||
| - | === Program Options === | + | Most of the items in the Edit menu, such as Copy, Paste, |
| - | + | ||
| - | Modify | + | |
| {{: | {{: | ||
| - | ===== View Menu ===== | + | ^ Menu Item ^ Description ^ |
| + | | Program Options | Opens the [[visual3d: | ||
| - | {{ : | ||
| - | The view menu contains a miscellaneous set of commands related to the interface. | + | ===== View Menu ===== |
| - | + | ||
| - | === Toolbar === | + | |
| - | + | ||
| - | Toggles on/off the toolbar | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | ===Large Toolbar=== | + | |
| - | + | ||
| - | Toggles the large or small toolbar | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === Status Bar === | + | |
| - | + | ||
| - | toggles the status bar at the bottom left of the window | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Popup Wizard | + | |
| - | + | ||
| - | Toggles the popup wizard | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === Long Filenames === | + | |
| - | + | ||
| - | Toggles between the filename and the full path | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View HAS-Motion Visual3D Banner === | + | |
| - | + | ||
| - | Toggles the display of a banner at the top of the 3D view | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Color Mapped Lines on Signal and Event Processing Graphs === | + | |
| - | + | ||
| - | Toggles between Black lines and Colored lines on the interactive graphs | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Graph Animation Frame Line === | + | |
| - | + | ||
| - | Add a vertical line indicating the current frame in the animation window | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Synchronized Video === | + | |
| - | + | ||
| - | View Synchronized Video | + | |
| - | + | ||
| - | {{: | + | |
| - | === Set Camera Perspective === | + | The view menu contains commands related to Visual3D' |
| - | Set the camera view in the 3D Viewer | + | {{: |
| - | {{:SetCameraPerspective.jpg}} | + | ^ Menu Item ^ Description ^ |
| + | | Toolbar | Toggles the toolbar on/ | ||
| + | | Status Bar | Toggles whether status updates appear in the application' | ||
| + | | Program Options | Opens the [[visual3d: | ||
| + | | Large Toolbar | Toggles between large and small toolbar icons. {{ : | ||
| + | | Long Filenames | Toggles between displaying files as the filename or the complete path on disk. {{: | ||
| + | | View HAS-Motion Visual3D Banner | Toggles the display of a banner at the top of the 3D view | ||
| + | | View Color Mapped Lines on Signal and Event Processing Graphs | Toggles whether lines on the interactive graphs are black or coloured according to file. | | ||
| + | | View Graph Animation Frame Line | Add a vertical line indicating the current frame in the animation window. | | ||
| + | | View Synchronized Video | View Synchronized Video | | ||
| + | | Set Camera Perspective | Set the camera view in the 3D Viewer. | | ||
| === Processing Results === | === Processing Results === | ||
| Line 263: | Line 157: | ||
| {{: | {{: | ||
| - | === Modify Lab Coordinate System === | + | ==== Modify Lab Coordinate System |
| Changes the X, Y and Z directions for the lab. | Changes the X, Y and Z directions for the lab. | ||
| - | === Modify Scale of the 3D Graphics Objects === | + | ==== Modify Scale of the 3D Graphics Objects |
| Allows the user to change the size of the displayed targets. | Allows the user to change the size of the displayed targets. | ||
| Line 273: | Line 167: | ||
| {{: | {{: | ||
| - | === Use Processed Analogs for Ground Reaction Force Calculations === | + | ==== Use Processed Analogs for Ground Reaction Force Calculations |
| Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\ | Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\ | ||
| Line 279: | Line 173: | ||
| {{: | {{: | ||
| - | === Use Processed Forces for Segment to Force Assignment === | + | ==== Use Processed Forces for Segment to Force Assignment |
| Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D: | Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D: | ||
| - | === Use Processed Targets for Model/ | + | ==== Use Processed Targets for Model/ |
| Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, | Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, | ||
| Line 289: | Line 183: | ||
| [[Visual3D: | [[Visual3D: | ||
| - | === Use Biomechanics Conventions === | + | ==== Use Biomechanics Conventions |
| Biomechanics conventions refer to the meaning for medial/ | Biomechanics conventions refer to the meaning for medial/ | ||
| Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments. | Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments. | ||
| + | |||
| + | If the name of a segment begins with the letter L, and Biomechanics Conventions are selected, the segment is treated as a left side segment, otherwise the segment is treated as a right side segment. | ||
| + | |||
| If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards. | If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards. | ||
| - | === Use Compatible 1 Byte Characters === | + | ==== Use Compatible 1 Byte Characters |
| There are some unicode characters that Visual3D cannot recognize. | There are some unicode characters that Visual3D cannot recognize. | ||
| - | === Use dd/mm/yyyy (European/ | + | ==== Use dd/mm/yyyy (European/ |
visual3d/getting_started/menus.1734003034.txt.gz · Last modified: by wikisysop
