visual3d:getting_started:menus
Differences
This shows you the differences between two versions of the page.
| Both sides previous revisionPrevious revisionNext revision | Previous revision | ||
| visual3d:getting_started:menus [2024/11/15 19:37] – [View Menu] wikisysop | visual3d:getting_started:menus [2026/08/27 19:34] (current) – Reformatting sections into tables and updating to current UI. richard | ||
|---|---|---|---|
| Line 1: | Line 1: | ||
| - | ====== Menus ====== | + | ====== |
| - | Although many of the features in Visual3D can be accessed in multiple ways, the drop-down menus across the top of the Visual3D | + | EDIT IN PROGRESS |
| + | |||
| + | Most features in Visual3D can be accessed in multiple ways. The drop-down menus across the top of the Visual3D | ||
| {{: | {{: | ||
| - | This Visual3D Menus link provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here. | + | This page provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here. |
| ===== File Menu ===== | ===== File Menu ===== | ||
| Line 11: | Line 13: | ||
| The File menu item is used to manage files opened or saved by Visual 3D. | The File menu item is used to manage files opened or saved by Visual 3D. | ||
| - | {{ : | + | {{: |
| - | The menu subitems are: | + | ^ Menu Item ^ Description ^ |
| + | | New | Closes all open files, leaving a new, i.e., empty, workspace. | | ||
| + | | Open/Add | Opens a new motion document (C3D, CMZ, H5, etc.) | | ||
| + | | Close | Closes the currently active motion file(s) as indicated by the active file selection box. | | ||
| + | | Save Workspace | Saves all open files to the current workspace document (CMZ or H5). | | ||
| + | | Save Workspace As | Prompts the user with the file save dialog in order to save all open files to a new or existing workspace document (CMZ or H5). | | ||
| + | | Save Workspace With Embedded Segment Graphics As | Workspace files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). This option allows the user to include the wire mesh frames within the workspace file. | | ||
| + | | Export | {{:ExportMenu.png? | ||
| + | | > Export C3D File | Exports an opened file to a C3D File (.c3d). | | ||
| + | | > Export C3DFile for Vicon Polygon | Runs the pipeline command [[Visual3D: | ||
| + | | > Export Animation to AVI | Exports the 3D animation to an AVI (.avi) file. | | ||
| + | | > Export Animation Frame to Image | Exports the current animation viewer frame to a supported image file format (.jpg, .png, .gif, .bmp). | | ||
| + | | > Export OpenSim Motion File | | | ||
| + | | > Export OpenSim Motion File without CleanUp | | | ||
| + | | > Export OpenSim Motion File from Data Tree | | | ||
| + | | View Workspace History | | | ||
| + | | Open Report Template | | | ||
| + | | Append Report Template | | | ||
| + | | Save Report Template | | | ||
| + | | Add/Modify File Tags | Brings up a window to add/modify file tags for currently open motion files in the workspace. | | ||
| + | | Add/Modify Synchronized Video Files | [[Add_Modify_Synchronized_Video_Files]] Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. | | ||
| + | | Add/Modify Synchronized Motion Files | [[Add_Modify_Synchronized_Motion_Files]] Allows multiselection of C3D motion files and frame offsets for synchronized playback. | | ||
| + | | Print | Prints the current report. | | ||
| + | | Print Preview | Previews the current report before printing. | | ||
| + | | Print Setup | Change the printer and printer options used by Visual3D. | | ||
| + | | < Recently Opened Motion Files > | Displays the last four opened motion files for easy re-opening. | | ||
| + | | Exit | Exits the Visual 3D application. | | ||
| - | === New === | + | ===== Edit Menu ===== |
| - | Closes all open files, leaving an empty workspace. | + | Most of the items in the Edit menu, such as Copy, Paste, and Cut, provide behaviour that is consistent with these commands across the operating system. |
| - | === Open === | + | {{: |
| - | Opens a new motion document (C3D, CMZ, etc.) | + | ^ Menu Item ^ Description ^ |
| + | | Program Options | Opens the [[visual3d: | ||
| - | === Close === | ||
| - | Closes the currently active motion file(s) as indicated by the active file selection box. | + | ===== View Menu ===== |
| - | === Save Workspace === | + | The view menu contains commands related |
| - | + | ||
| - | Saves all open files to the current C-Motion (cmz) Document. | + | |
| - | + | ||
| - | === Save Workspace As === | + | |
| - | + | ||
| - | Prompts the user with the file save dialog in order to save all open files to a new or existing C-Motion (cmz) Document. | + | |
| - | + | ||
| - | === Export === | + | |
| - | + | ||
| - | {{ : | + | |
| - | + | ||
| - | == Export C3D File == | + | |
| - | + | ||
| - | Exports an opened file to a C3D File (.c3d). | + | |
| - | + | ||
| - | == Export C3DFile for Vicon Polygon == | + | |
| - | + | ||
| - | Pipeline Command | + | |
| - | + | ||
| - | [[Visual3D: | + | |
| - | + | ||
| - | == Export Animation to AVI == | + | |
| - | + | ||
| - | Exports the 3D animation to an AVI (.avi) file. | + | |
| - | + | ||
| - | == Export Animation Frame to Image == | + | |
| - | + | ||
| - | Exports the current animation viewer frame to an Image (.jpg, .png, .gif, .bmp). | + | |
| - | + | ||
| - | == Export Standalone CMO for Viewer == | + | |
| - | + | ||
| - | CMO files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). | + | |
| - | + | ||
| - | CMO files intended for the Free CMO viewer, however, must explicitly embed the graphics by selecting the export option to include the graphics. | + | |
| - | + | ||
| - | === Add Modify File Tags === | + | |
| - | + | ||
| - | Brings up a window to add/modify file tags | + | |
| - | + | ||
| - | === Add Modify Synchronized Video Files === | + | |
| - | + | ||
| - | Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. | + | |
| - | + | ||
| - | + | ||
| - | === Add Modify Synchronized Motion Files === | + | |
| - | + | ||
| - | Allows multiselection of C3D motion files and frame offsets for synchronized playback. | + | |
| - | + | ||
| - | === Modify Force Platform Parameters === | + | |
| - | + | ||
| - | Allows modification of the active file(s) force platform C3D file parameters | + | |
| - | + | ||
| - | === Print === | + | |
| - | + | ||
| - | Prints the current report | + | |
| - | + | ||
| - | === Print Preview === | + | |
| - | + | ||
| - | Previews the current report. | + | |
| - | + | ||
| - | === Print Setup === | + | |
| - | + | ||
| - | Change the printer and printer options. | + | |
| - | + | ||
| - | === Exit === | + | |
| - | + | ||
| - | Exits the Visual 3D application. | + | |
| - | + | ||
| - | ===== View Menu ===== | + | |
| {{: | {{: | ||
| - | The view menu contains a miscellaneous set of commands related to the interface. | + | ^ Menu Item ^ Description ^ |
| - | + | | Toolbar | |
| - | === Toolbar | + | | Status Bar | Toggles whether |
| - | + | | Program Options | Opens the [[visual3d: | |
| - | Toggles on/ | + | | Large Toolbar | Toggles |
| - | + | | Long Filenames | |
| - | {{: | + | | View HAS-Motion Visual3D Banner |
| - | + | | View Color Mapped Lines on Signal and Event Processing Graphs | |
| - | **Large Toolbar** - toggles the large or small toolbar | + | | View Graph Animation Frame Line | Add a vertical line indicating the current frame in the animation window. |
| - | + | | View Synchronized Video | View Synchronized Video | | |
| - | {{: | + | | Set Camera Perspective |
| - | + | ||
| - | === Status Bar === | + | |
| - | + | ||
| - | toggles the status | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Popup Wizard === | + | |
| - | + | ||
| - | Toggles | + | |
| - | + | ||
| - | {{:CommandWizard.jpg}} | + | |
| - | + | ||
| - | === Long Filenames | + | |
| - | + | ||
| - | Toggles between the filename | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View HAS-Motion Visual3D Banner | + | |
| - | + | ||
| - | toggles | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Color Mapped Lines on Signal and Event Processing Graphs | + | |
| - | + | ||
| - | Toggles | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Graph Animation Frame Line === | + | |
| - | + | ||
| - | Add a vertical line indicating the current frame in the animation window | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === View Synchronized Video === | + | |
| - | + | ||
| - | View Synchronized Video | + | |
| - | + | ||
| - | {{: | + | |
| - | + | ||
| - | === Set Camera Perspective | + | |
| - | + | ||
| - | Set the camera view in the 3D Viewer | + | |
| - | + | ||
| - | {{: | + | |
| === Processing Results === | === Processing Results === | ||
| Line 224: | Line 133: | ||
| === View/Edit Segment to Force assignments === | === View/Edit Segment to Force assignments === | ||
| - | modify | + | Modify |
| === Color Item with Signal Value === | === Color Item with Signal Value === | ||
| Allows the user to map signals to segments, and select color values to color a segment based upon the signal values. | Allows the user to map signals to segments, and select color values to color a segment based upon the signal values. | ||
| + | |||
| + | ===== Force ===== | ||
| + | |||
| + | ==== Minimum Force ==== | ||
| + | |||
| + | Visual3D' | ||
| + | |||
| + | {{: | ||
| + | |||
| + | Applying a threshold value to the force signals ensures that If the computed force is less than the minimum force, then the FORCE and FREEMOMENT are set to zero, the COFP is set to [[Visual3D: | ||
| + | |||
| + | {{: | ||
| ===== Settings ===== | ===== Settings ===== | ||
| Line 236: | Line 157: | ||
| {{: | {{: | ||
| - | === Modify Lab Coordinate System === | + | ==== Modify Lab Coordinate System |
| Changes the X, Y and Z directions for the lab. | Changes the X, Y and Z directions for the lab. | ||
| - | === Modify Scale of the 3D Graphics Objects === | + | ==== Modify Scale of the 3D Graphics Objects |
| Allows the user to change the size of the displayed targets. | Allows the user to change the size of the displayed targets. | ||
| Line 246: | Line 167: | ||
| {{: | {{: | ||
| - | === Use Processed Analogs for Ground Reaction Force Calculations === | + | ==== Use Processed Analogs for Ground Reaction Force Calculations |
| Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\ | Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\ | ||
| Line 252: | Line 173: | ||
| {{: | {{: | ||
| - | === Use Processed Forces for Segment to Force Assignment === | + | ==== Use Processed Forces for Segment to Force Assignment |
| Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D: | Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D: | ||
| - | === Use Processed Targets for Model/ | + | ==== Use Processed Targets for Model/ |
| Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, | Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, | ||
| Line 262: | Line 183: | ||
| [[Visual3D: | [[Visual3D: | ||
| - | === Use Biomechanics Conventions === | + | ==== Use Biomechanics Conventions |
| Biomechanics conventions refer to the meaning for medial/ | Biomechanics conventions refer to the meaning for medial/ | ||
| Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments. | Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments. | ||
| - | If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards. | ||
| - | === Use Compatible 1 Byte Characters === | + | If the name of a segment begins with the letter L, and Biomechanics Conventions are selected, the segment is treated as a left side segment, otherwise the segment is treated as a right side segment. |
| - | There are some unicode characters | + | If Biomechanics Conventions |
| - | === Use dd/mm/yyyy (European/ | + | ==== Use Compatible 1 Byte Characters ==== |
| - | === Program Options === | + | There are some unicode characters that Visual3D cannot recognize. |
| - | Modify the default folders and the default viewing options. | + | ==== Use dd/mm/yyyy (European/ |
| - | {{: | ||
| ===== Pipeline Menu ===== | ===== Pipeline Menu ===== | ||
visual3d/getting_started/menus.1731699457.txt.gz · Last modified: by wikisysop
