User Tools

Site Tools


visual3d:getting_started:menus

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
visual3d:getting_started:menus [2024/11/15 19:32] – [Export] wikisysopvisual3d:getting_started:menus [2026/08/27 19:34] (current) – Reformatting sections into tables and updating to current UI. richard
Line 1: Line 1:
-====== Menus ======+====== Visual3D Menus ======
  
-Although many of the features in Visual3D can be accessed in multiple ways, the drop-down menus across the top of the Visual3D page offer a familiar method of program interaction that is common to Windows-based software.+EDIT IN PROGRESS 
 + 
 +Most features in Visual3D can be accessed in multiple ways. The drop-down menus across the top of the Visual3D application window offer a familiar method of program interaction that is common to Windows-based software.
  
 {{:Menus1_Arrow.JPG}} {{:Menus1_Arrow.JPG}}
  
-This Visual3D Menus link provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here.+This page provides details on the options available through these drop-down menus. Because we are constantly adding more features, the menus in Visual3D often change before this documentation can be updated. Please contact us if there are features on the menus that are not described here.
  
 ===== File Menu ===== ===== File Menu =====
Line 11: Line 13:
 The File menu item is used to manage files opened or saved by Visual 3D. The File menu item is used to manage files opened or saved by Visual 3D.
  
-{{ :FileMenu.jpg?250}}+{{:FileMenu.jpg?250}}
  
-The menu subitems are:+^ Menu Item ^ Description ^ 
 +| New | Closes all open files, leaving a new, i.e., empty, workspace. | 
 +| Open/Add | Opens a new motion document (C3D, CMZ, H5, etc.) | 
 +| Close | Closes the currently active motion file(s) as indicated by the active file selection box. | 
 +| Save Workspace | Saves all open files to the current workspace document (CMZ or H5). | 
 +| Save Workspace As | Prompts the user with the file save dialog in order to save all open files to a new or existing workspace document (CMZ or H5). | 
 +| Save Workspace With Embedded Segment Graphics As | Workspace files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). This option allows the user to include the wire mesh frames within the workspace file. | 
 +| Export | {{:ExportMenu.png?500}} | 
 +| > Export C3D File | Exports an opened file to a C3D File (.c3d). | 
 +| > Export C3DFile for Vicon Polygon | Runs the pipeline command [[Visual3D:Documentation:Pipeline:File_Commands:Export_Polygon_C3DFile|Export_Polygon_C3DFile]]. | 
 +| > Export Animation to AVI | Exports the 3D animation to an AVI (.avi) file. | 
 +| > Export Animation Frame to Image | Exports the current animation viewer frame to a supported image file format (.jpg, .png, .gif, .bmp). | 
 +| > Export OpenSim Motion File | | 
 +| > Export OpenSim Motion File without CleanUp | | 
 +| > Export OpenSim Motion File from Data Tree | | 
 +| View Workspace History | | 
 +| Open Report Template | | 
 +| Append Report Template | | 
 +| Save Report Template | | 
 +| Add/Modify File Tags | Brings up a window to add/modify file tags for currently open motion files in the workspace. | 
 +| Add/Modify Synchronized Video Files | [[Add_Modify_Synchronized_Video_Files]] Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. | 
 +| Add/Modify Synchronized Motion Files | [[Add_Modify_Synchronized_Motion_Files]] Allows multiselection of C3D motion files and frame offsets for synchronized playback. | 
 +| Print | Prints the current report. | 
 +| Print Preview | Previews the current report before printing. | 
 +| Print Setup | Change the printer and printer options used by Visual3D. | 
 +| < Recently Opened Motion Files > | Displays the last four opened motion files for easy re-opening. | 
 +| Exit | Exits the Visual 3D application. |
  
-=== New ===+===== Edit Menu =====
  
-Closes all open filesleaving an empty workspace.+Most of the items in the Edit menusuch as Copy, Paste, and Cut, provide behaviour that is consistent with these commands across the operating system.
  
-=== Open ===+{{:ProgramOptions.png?400}}
  
-Opens a new motion document (C3DCMZ, etc.)+^ Menu Item ^ Description ^ 
 +| Program Options | Opens the [[visual3d:documentation:dialogs:program_options|Program Options]] dialogwhich allows the user to modify Visual3D's default folders and default viewing options|
  
-=== Close === 
  
-Closes the currently active motion file(s) as indicated by the active file selection box.+===== View Menu =====
  
-=== Save ===+The view menu contains commands related to Visual3D's graphical interface.
  
-Saves all open files to the current C-Motion (cmo) Document.+{{:ViewMenu.jpg}}
  
-=== Save As ===+^ Menu Item ^ Description ^ 
 +| Toolbar | Toggles the toolbar on/off. {{ :toolbar.jpg}} | 
 +| Status Bar | Toggles whether status updates appear in the application's bottom bar. {{ :StatusBar.jpg}}| 
 +| Program Options | Opens the [[visual3d:documentation:dialogs:program_options|Program Options]] dialog with the [[visual3d:documentation:dialogs:program_options#d_animation_options|3D Animation View]] tab active. | 
 +| Large Toolbar | Toggles between large and small toolbar icons. {{ :SmallToolbar.jpg}} | 
 +| Long Filenames | Toggles between displaying files as the filename or the complete path on disk. {{:SmallFilename.jpg}} {{:LongFilename.jpg}} | 
 +| View HAS-Motion Visual3D Banner | Toggles the display of a banner at the top of the 3D view 
 +| View Color Mapped Lines on Signal and Event Processing Graphs | Toggles whether lines on the interactive graphs are black or coloured according to file. | 
 +| View Graph Animation Frame Line | Add a vertical line indicating the current frame in the animation window. | 
 +| View Synchronized Video | View Synchronized Video | 
 +| Set Camera Perspective | Set the camera view in the 3D Viewer. |
  
-Prompts the user with the file save dialog in order to save all open files to a new or existing C-Motion (cmo) Document.+=== Processing Results ===
  
-=== Export ===+Displays the last set of Pipeline Processing Results
  
-{{ :ExportMenu.png?500}} +{{:ProcessingResults.jpg}}
- +
-== Export C3D File == +
- +
-Exports an opened file to a C3D File (.c3d). +
- +
-== Export C3DFile for Vicon Polygon == +
- +
-Pipeline Command +
- +
-[[Visual3D:Documentation:Pipeline:File_Commands:Export_Polygon_C3DFile|Export_Polygon_C3DFile]] +
- +
-== Export Animation to AVI == +
- +
-Exports the 3D animation to an AVI (.avi) file. +
- +
-== Export Animation Frame to Image == +
- +
-Exports the current animation viewer frame to an Image (.jpg, .png, .gif, .bmp). +
- +
-== Export Standalone CMO for Viewer == +
- +
-CMO files do not typically contain the wireframe meshes used for animating the surfaces of the bones because this information is supplied with Visual3D (e.g. as .v3g files). +
- +
-CMO files intended for the Free CMO viewer, however, must explicitly embed the graphics by selecting the export option to include the graphics. +
- +
-=== Add Modify File Tags === +
- +
-Brings up a window to add/modify file tags +
- +
-=== Add Modify Synchronized Video Files === +
- +
-Allows mapping of video files (.mpg, .avi, etc) to motion files for synchronized playback. +
- +
- +
-=== Add Modify Synchronized Motion Files === +
- +
-Allows multiselection of C3D motion files and frame offsets for synchronized playback. +
- +
-=== Modify Force Platform Parameters === +
- +
-Allows modification of the active file(s) force platform C3D file parameters +
- +
-=== Print === +
- +
-Prints the current report +
- +
-=== Print Preview === +
- +
-Previews the current report. +
- +
-=== Print Setup === +
- +
-Change the printer and printer options. +
- +
-=== Exit === +
- +
-Exits the Visual 3D application.+
  
 ===== Model Menu ===== ===== Model Menu =====
Line 152: Line 133:
 === View/Edit Segment to Force assignments === === View/Edit Segment to Force assignments ===
  
-modify the [[Visual3D:Documentation:Kinematics_and_Kinetics:External_Forces:Force_Assignment|segment assignments]]+Modify the [[Visual3D:Documentation:Kinematics_and_Kinetics:External_Forces:Force_Assignment|segment assignments]]
  
 === Color Item with Signal Value === === Color Item with Signal Value ===
Line 158: Line 139:
 Allows the user to map signals to segments, and select color values to color a segment based upon the signal values. Allows the user to map signals to segments, and select color values to color a segment based upon the signal values.
  
-===== View Menu =====+===== Force =====
  
-{{:ViewMenu.jpg}}+==== Minimum Force ====
  
-The view menu contains a miscellaneous set of commands related to the interface.+Visual3D's Force menu contains an option to set a threshold for force platform/structure data.
  
-=== Toolbar ===+{{:MinimumForceMenu.jpg}}
  
-Toggles on/off the toolbar+Applying a threshold value to the force signals ensures that If the computed force is less than the minimum force, then the FORCE and FREEMOMENT are set to zero, the COFP is set to [[Visual3D:Documentation:C3D_Signal_Types:DATA_NOT_FOUND|DATA_NOT_FOUND]]. This value can also be set using the pipeline command **[[Visual3D:Documentation:Pipeline:Force_Commands:Set_Force_Platform_Threshold|Set_Force_Platform_Threshold]]**. This command is listed under the **[[Visual3D:Documentation:Pipeline:Force_Commands:Force_Commands_Review|Force]]** category of the pipeline commands. This threshold value is used to remove noise from the force signals. Often for instrumented treadmills this value must be set higher than for overground gait trials.
  
-{{:toolbar.jpg}} +{{:MinimumForceDlg.jpg}}
- +
-**Large Toolbar** - toggles the large or small toolbar +
- +
-{{:SmallToolbar.jpg}} +
- +
-=== Status Bar === +
- +
-toggles the status bar at the bottom left of the window +
- +
-{{:StatusBar.jpg}} +
- +
-=== View Popup Wizard === +
- +
-Toggles the popup wizard +
- +
-{{:CommandWizard.jpg}} +
- +
-=== Long Filenames === +
- +
-Toggles between the filename and the full path +
- +
-{{:SmallFilename.jpg}} +
- +
-{{:LongFilename.jpg}} +
- +
-=== View HAS-Motion Visual3D Banner === +
- +
-toggles the display of a banner at the top of the 3D view +
- +
-{{:Visual3DBanner.jpg}} +
- +
-=== View Color Mapped Lines on Signal and Event Processing Graphs === +
- +
-Toggles between Black lines and Colored lines on the interactive graphs +
- +
-{{:26WGraph.jpg}} +
- +
-{{:ColoredGraph.jpg}} +
- +
-=== View Graph Animation Frame Line === +
- +
-Add a vertical line indicating the current frame in the animation window +
- +
-{{:GraphAnimationFrameLine.jpg}} +
- +
- +
-=== View Synchronized Video === +
- +
-View Synchronized Video +
- +
-{{:Video.jpg}} +
- +
-=== Set Camera Perspective === +
- +
-Set the camera view in the 3D Viewer +
- +
-{{:SetCameraPerspective.jpg}} +
- +
- +
-=== Processing Results === +
- +
-Displays the last set of Pipeline Processing Results +
- +
-{{:ProcessingResults.jpg}} +
- +
-===== Pipeline Menu ===== +
- +
-{{:PipelineMenu.jpg}} +
- +
-The pipeline menu contains the recent pipelines that were executed. Selecting a pipeline will cause it to be loaded and executed automatically. +
- +
-Select **View Pipeline** is equivalent to selecting the **View Pipeline icon** on the Toolbar.+
  
 ===== Settings ===== ===== Settings =====
Line 248: Line 157:
 {{:ModifyTargetSize1.jpg}} {{:ModifyTargetSize1.jpg}}
  
-=== Modify Lab Coordinate System ===+==== Modify Lab Coordinate System ====
  
 Changes the X, Y and Z directions for the lab. Changes the X, Y and Z directions for the lab.
  
-=== Modify Scale of the 3D Graphics Objects ===+==== Modify Scale of the 3D Graphics Objects ====
  
 Allows the user to change the size of the displayed targets. Allows the user to change the size of the displayed targets.
Line 258: Line 167:
 {{:ModifyTargetSize2.jpg}} {{:ModifyTargetSize2.jpg}}
  
-=== Use Processed Analogs for Ground Reaction Force Calculations ===+==== Use Processed Analogs for Ground Reaction Force Calculations ====
  
 Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\ Specify whether the original or processed analog signals should be used for computing the Ground Reaction Force\\
Line 264: Line 173:
 {{:AMTI_Tutorial5.jpg}} {{:AMTI_Tutorial5.jpg}}
  
-=== Use Processed Forces for Segment to Force Assignment ===+==== Use Processed Forces for Segment to Force Assignment ====
  
 Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D:Documentation:Kinematics_and_Kinetics:External_Forces:Force_Assignment|Force Assignments]]. Specify that processed FORCE, COFP, and FREEMOMENT signals should be used for determining the [[Visual3D:Documentation:Kinematics_and_Kinetics:External_Forces:Force_Assignment|Force Assignments]].
  
-=== Use Processed Targets for Model/Segment/LinkModelBased Items ===+==== Use Processed Targets for Model/Segment/LinkModelBased Items ====
  
 Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, etc. Specify whether the original or processed targets are to be used for determining model segment locations, model based computations, etc.
Line 274: Line 183:
 [[Visual3D:Documentation:Visual3D_Signal_Types:LINK_MODEL_BASED_Data_Type#Using_PROCESSED_Signals|An explanation for Using Processed Signals is here]] [[Visual3D:Documentation:Visual3D_Signal_Types:LINK_MODEL_BASED_Data_Type#Using_PROCESSED_Signals|An explanation for Using Processed Signals is here]]
  
-=== Use Biomechanics Conventions ===+==== Use Biomechanics Conventions ====
  
 Biomechanics conventions refer to the meaning for medial/lateral, anterior/posterior, and axial for the left and right side segments. Biomechanics conventions refer to the meaning for medial/lateral, anterior/posterior, and axial for the left and right side segments.
  
 Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments. Note that medial and lateral are defined with respect to the subject in the Anatomical Position, which is important to remember when defining the forearm and hand segments.
 +
 +If the name of a segment begins with the letter L, and Biomechanics Conventions are selected, the segment is treated as a left side segment, otherwise the segment is treated as a right side segment.
 +
 If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards. If Biomechanics Conventions are not selected, all coordinate system use the right hand rule, and left and right side segments are created equivalently. The typical consequence is that the left side segments look like they are constructed backwards.
  
-=== Use Compatible 1 Byte Characters ===+==== Use Compatible 1 Byte Characters ====
  
 There are some unicode characters that Visual3D cannot recognize. There are some unicode characters that Visual3D cannot recognize.
  
-=== Use dd/mm/yyyy (European/Canadian format) Dates ===+==== Use dd/mm/yyyy (European/Canadian format) Dates ====
  
-=== Program Options === 
  
-Modify the default folders and the default viewing options.+===== Pipeline Menu =====
  
-{{:ProgramOptions.png}}+{{:PipelineMenu.jpg}} 
 + 
 +The pipeline menu contains the recent pipelines that were executed. Selecting a pipeline will cause it to be loaded and executed automatically. 
 + 
 +Select **View Pipeline** is equivalent to selecting the **View Pipeline icon** on the Toolbar.
visual3d/getting_started/menus.1731699155.txt.gz · Last modified: by wikisysop